e463. 數數字

題目 Problem

題目連結:https://zerojudge.tw/ShowProblem?problemid=e463

敘述 Description

給你一個數字n(n<=100),可以在n旁邊加上<=n/2的數字,一直加到不能加為止

比如說n=6,可以變成16,26,36

26可以變成126

36可以變成136

最後總共有6,16,26,36,126,136共六個數字

輸入 Input

多筆輸入

每行為n(n<=100)

輸出 Output

輸出共有幾個數字

再輸出每個數字,記得要排序

(有一些數字雖然會重複,但因為是由不同數字變出來的,所以都要輸出)

範例輸入 Sample Input

1
2
6
10

範例輸出 Sample Output

1
2
3
4
6
6 16 26 36 126 136
14
10 110 210 310 410 510 1210 1310 1410 1510 2410 2510 12410 12510

提示 Hint

不准作弊!

題解 Solution

搭配 DFS + Multiset
不能使用 Set 的原因是有些數字會是重複產生,但是必須要讓它輸出

深度當前的那個數字 $n$,然後從 $1$ 到 $\frac{n}{2}$ 再向下搜尋
Line 64 的 s 是計算要加入數字的長度

程式碼 Accepted Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
/*
Author: Jerry Yang C.H. (tico88612)
Date: 2020/2/16
*/
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
typedef pair<ll, ll> pii;
typedef pair<double,double> pdd;
#define SQ(i) ((i)*(i))
#define MEM(a, b) memset(a, (b), sizeof(a))
#define SZ(i) int(i.size())
#define FOR(i, j, k, in) for (int i=j ; i<k ; i+=in)
#define RFOR(i, j, k, in) for (int i=j ; i>=k ; i-=in)
#define REP(i, j) FOR(i, 0, j, 1)
#define REP1(i,j) FOR(i, 1, j+1, 1)
#define RREP(i, j) RFOR(i, j, 0, 1)
#define ALL(_a) _a.begin(),_a.end()
#define MP make_pair
#define PB push_back
#define EB emplace_back
#define X first
#define Y second
#ifdef tmd
#define debug(...) do{\
fprintf(stderr,"%s - %d (%s) = ",__PRETTY_FUNCTION__,__LINE__,#__VA_ARGS__);\
_do(__VA_ARGS__);\
}while(0)
template<typename T>void _do(T &&_x){cerr<<_x<<endl;}
template<typename T,typename ...S> void _do(T &&_x,S &&..._t){cerr<<_x<<" ,";_do(_t...);}
template<typename _a,typename _b> ostream& operator << (ostream &_s,const pair<_a,_b> &_p){return _s<<"("<<_p.X<<","<<_p.Y<<")";}
template<typename It> ostream& _OUTC(ostream &_s,It _ita,It _itb)
{
_s<<"{";
for(It _it=_ita;_it!=_itb;_it++)
{
_s<<(_it==_ita?"":",")<<*_it;
}
_s<<"}";
return _s;
}
template<typename _a> ostream &operator << (ostream &_s,vector<_a> &_c){return _OUTC(_s,ALL(_c));}
template<typename _a> ostream &operator << (ostream &_s,set<_a> &_c){return _OUTC(_s,ALL(_c));}
template<typename _a> ostream &operator << (ostream &_s,deque<_a> &_c){return _OUTC(_s,ALL(_c));}
template<typename _a,typename _b> ostream &operator << (ostream &_s,map<_a,_b> &_c){return _OUTC(_s,ALL(_c));}
template<typename _t> void pary(_t _a,_t _b){_OUTC(cerr,_a,_b);cerr<<endl;}
#define IOS()
#else
#define debug(...)
#define pary(...)
#define endl '\n'
#define IOS() ios_base::sync_with_stdio(0);cin.tie(0)
#endif

const ll MOD = 1000000007LL;
const ll INF = 0x3f3f3f3f3f3f3f3fLL;
const int iNF = 0x3f3f3f3f;
// const ll MAXN =

multiset<ll> ms;

void dfs(ll n, ll now){
ms.insert(now);
ll s = pow(10, (ll)(log10(now) + 1));
REP1(i, n / 2){
dfs(i, now + i * s);
}
}

void play(ll n){
ms.clear();
dfs(n, n);
cout << SZ(ms) << '\n';
int fir = 1;
for(auto i: ms){
if(fir){
fir = 0;
}
else{
cout << " ";
}
cout << i;
}
cout << '\n';
}

/********** Good Luck :) **********/
int main()
{
IOS();
ll n;
while(cin >> n){
play(n);
}
return 0;
}

後記 Afterword

That’s it.
暫時不知道要寫啥


e463. 數數字
https://blog.yangjerry.tw/2020/02/16/zj-e463/
作者
Jerry Yang
發布於
2020年2月16日
許可協議